Отмена перехода на зимнее время на Cisco

  • Cisco
В связи с отменой перехода на сезонное время, на всех сетевых устройствах, которые поддерживают автоматическую смену зимнего/летнего времени необходимо произвести изменения конфигурации. Это касается как Cisco так и не Cisco оборудования. Клиент должен обратиться ко всем производителям, оборудование которых использует всевозможные методы коммуникации, связанные с указанием времени, чтобы оценить степень влияния отказа от смены сезонного времени на устройствах.
Если не изменить данные настройки на оборудовании, после 30 октября 2011 года оно будет отображать не корректную информацию о времени – отличаться на 1 час от актуального времени. Несоответствие актуальному времени чрезвычайно затруднит процесс мониторинга и решения проблем, так как сложно будет определить правильную последовательность прошедших событий. Не корректная установка времени может привести к проблемам на AAA серверах и соответственно к проблемам с доступом на устройства и сбором биллинговой информации.
Читать дальше →

Обнаружение NBAR Flesh Tone в Cisco IOS

  • Cisco
Чтобы помочь в борьбе с большим трафиком в общественном интернете, Cisco разработала приложение Network-Based Application Recognition (NBAR) встроенное в маршрутизаторы на базе IOS. Обнаружение NBAR Flesh Tone работает с помощью глубокой инспекции пакетов (DPI) и ищет порнографические изображения для понижения их приоритета.

Приложение обнаруживает изображения с большим количеством тонов бежево-коричневый цвета, общие для человеческого пигментов кожи. Изображения с высоким процентом пикселей этих цветов могут быть порнографического характера. Обнаружение NBAR Flesh Tone может обрабатывать изображения загружаемые с помощью HTTP и FTP используя эвристическое обнаружение и помечать пакеты с подозрительными фрагментами для понижения приоритета.

Обнаружение NBAR Flesh Tone, работает на проприоритарном алгоритме Flexible Advanced Pornographic Protocol Recognition (FAPPR) и в настоящее время поддерживает JPG, PNG, TIFF, GIF, анимированный GIF и форматы изображения до 2048x2048 пикселей.

Пример настройки:
class-map hardcore
  match flesh-tone percentage 60

policy-map skintastic
  class hardcore
    priority percent 90

interface ethernet 2/4
 service-policy input skintastic

Читать дальше →

Управление конфигурациями Cisco в небольших сетях

  • Cisco
На крупных предприятиях и у провайдеров принята практика регулярного резервного копирования конфигурации всех устройств сети. Эти резервные копии могут быть использованы в случае чрезвычайной ситуации для восстановления конфигурации устройства, которая была случайно изменена или удалена. Работает это например по tftp или интегрировано с системой сетевого управления CiscoWorks.

Однако, этот подход плохо подходит для малого/среднего офиса. В ситуациях, где присутствует только один или несколько устройств, такой метод практически не имеет смысла.

Cisco IOS включает в себя функцию архива конфигураций, который позволяет создавать вручную или автоматически снимки конфигурации хранящиеся локально на собственной файловой системе маршрутизатора.

Чтобы включить эту функцию, мы создадим папку archive и в конфигурации укажем путь, где архив конфигурации будет храниться:
Читать дальше →

IOS 15.1 и команда DO

  • Cisco
В режимен конфигурации раньше в 12.4 спокойно работала команда do wr, сейчас в 15.1 почему то нет. Кто-нибудь знает почему?

router(config)#do wr
                  ^
% Invalid input detected at '^' marker.

router(config)#exit
router#wr
Building configuration...

[OK]

Мелочь, а непонятно…

Полезные команды в Cisco IOS [6]

  • Cisco
1. Сброс настроек интерфейса
Router(config)#default interface fa0/0
Building configuration...

2. Escape sequence
Пресловутый escape sequence с Ctrl+Shift+6 можно изменить на например Ctrl+W
Router#terminal escape-character 23          ! 23 = Ctrl+W
"^W" is the escape character 

3. Translating “...”
Иногда ошибаешься в команде и появляется Translating “наша недокоманда”. Можно отключить поиск в dns, чтобы этого не происходило.
Router(config)#no ip domain-lookup

Читать дальше →

Полезные команды в Cisco IOS [5]

  • Cisco
Горячие клавиши

Полезные сочетания клавиш, чтобы лишний раз не пользоваться мышкой.

Ctrl+A — Передвинуть курсор на начало строки
Ctrl+E — Передвинуть курсор на конец строки
Up — Последняя команда из истории
Down — Следующая команда из истории
Ctrl+W — Стереть предыдущее слово
Ctrl+U — Стереть всю линию
Ctrl+C — Выход из режима конфигурирования
Ctrl+Z — Применить текущую команду и выйти из режима конфигурирования
Ctrl+Shift+6 — Остановка длительных процессов — тот самый «Type escape sequence to abort»

Параметры вывода

После основного текста команды через символ | можно указать модификаторы вывода, которые очень полезны. Ими можно фильтровать строки, секции, позицию вывода. Вот основные:
Читать дальше →

Настройка маршрутизаторов Cisco

  • Cisco
Я уже выкладывал в этом блоге несколько постов про команды cisco ios, но они служат в том числе и справочником мне, потому что я иногда возвращаюсь к ним, чтобы вспомнить команды. Теперь я решил написать статьи про начальную настройку маршрутизаторов cisco, потому что вопросы по ним возникают часто, а ссылку дать и некуда :)
Читать дальше →

Настройка reflexive access-list в cisco, что это и зачем нужно?

  • Cisco
Рефлексивные списки доступа являются одним из методов, который добавит функции брандмауэра в маршрутизатор. Они обычно используются для пропуска исходящего трафика и проверку входящего трафика в ответ для сессий, которые созданы внутри маршрутизатора. Например Вы хотите, чтобы TCP соединение пропускалось извне только начальный пакет был направлен с внутреннего интерфейса. Например FTP сеанса по порту TCP 20. Если вы обращаетесь к FTP изнутри LAN по порту 20, то будет пропускаться и исходящий и входящий трафик. Но если кто-то из-за пределов попытается инициировать сессию на порт 20, сессия будет прекращена.

Пример как добавить Reflexive access-list и «повесить» их на интерфейс.
ip access-list extended OUTBOUND
permit tcp any any reflect TO_REFLECT
permit udp any any reflect TO_REFLECT

ip access-list extended INBOUND
evaluate TO_REFLECT

interface  GigabitEthernet0/1
ip access-group OUTBOUND out
ip access-group INBOUND in


UPD
Протестировал из дома соединение с cisco настроенной по такому методу, nmap выдает по всем скриптам
Note: Host seems down. If it is really up, but blocking our ping probes, try -PN
Хотя до этого даже с закрытыми портам получалось получить некоторую информацию

Обновление прошивки в Cisco

  • Cisco
Обновить прошивку в Cisco не сложно:
1. Сохраняем старую прошивку (на всякий случай)
2. Копируем на флешку новую прошивку.
3. Удаляем старую прошивку.
4. Перегружаем девайс.
Можно использовать в последовательностях 3,2,4 или 2,3,4, но я бы рекомендовал 1,2,3,4 :)
Метод подойдет как для ios так и для pix/asa.

Теперь подробней:
Читать дальше →

Полезные команды в Cisco IOS [4]

  • Cisco
1. Удобный просмотр состояния интерфейсов:
#show ip int brief | excl unassigned
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         123.12.198.55   YES NVRAM  up                    up
GigabitEthernet0/1         172.18.48.10    YES NVRAM  up                    up
Vlan30                     172.18.88.90    YES NVRAM  up                    up
NVI0                       192.168.1.21    YES unset  up                    up
Loopback0                  192.168.1.21    YES NVRAM  up                    up
можно добавить алиас на эту команду, чтобы в дальнейшем вызывать ее как ipconfig
alias exec ipconfig show ip interface brief | exclude unassigned

2. Уменьшить время ожидания при открытии ssh/telnet сессии:
Бывает пытаешься открыть удаленный хост по ssh/telnet, а он не доступен. Тогда приходится ждать 30 секунд и никакие ctrl+shift+6 не спасают. Спастись можно если добавить в конфиг предварительно:
ip tcp synwait-time 5
Тогда время ожидания уменьшится до 5.

Похожие статьи:
Полезные команды в Cisco IOS [1]
Полезные команды в Cisco IOS [2]
Полезные команды в Cisco IOS [3]
Полезные команды в Cisco IOS [5]
Полезные команды в Cisco IOS [6]

Ускорение sh run в Cisco IOS

  • Cisco
Наткнулся в буржуйском блоге на интересную команду в cisco ios. Если в конфиг добавить
parser config cache interface
то команды
copy system:running-configuration
show running-configuration
write terminal
работают в 2-3 раза быстрее. Особенно актуально на разросшихся конфигурациях, которые бывает формируются больше 5-10 секунд.
Команда появилась начиная с IOS версии 12.2(25).


Читать дальше →

Cisco маршрутизатор и 2 провайдера

  • Cisco
Нашей задачей будет заставить работать 2 внешних интерфейса одновременно с автоматическим переключением на рабочий. Плюс немного усложним задачу, часть трафика нужно будет принудительно направить в резервный канал независимо от работоспособности.

Схема подключения



Читать дальше →