admin
Рейтинг
+12.14
Сила
24.41

admin

admin

Хакер в столовой

  • Юмор
День первый
Хакер приходит в общественную столовую и с возмущением обнаруживает, что солонку на столе может открутить кто попало и насыпать туда что угодно. Хакер приходит домой и пишет гневное письмо директору столовой: «Я, meG@Duc, обнаружил уязвимость солонки в Вашей столовой. Злоумышленник может вскрыть солонку и насыпать туда яду! Примите меры срочно!»

День второй
Директор среди прочих деловых писем, запросов о поставках еды и курьерских уведомлений получает письмо, и пожимает плечами: «Кому этот бред только в голову пришёл?»

День пятый
Хакер приходит в столовую, насыпает во все солонки яду. Погибает триста человек, директора три месяца таскают по судам и в конце концов оправдывают за отсутствием состава преступления. Хакер пишет письмо в стиле «ну что, видали?».
Читать дальше →

Релиз Asterisk 12 выйдет в 2013 году

  • Asterisk
Информация с сайта разработчика:
В стандартном релизе целью развития этой версии Asterisk является архитектурные усовершенствования, а также основные новые функции. Такие как:
  • Новый расширяемый и производительный драйвер SIP канала построенный на стеке SIP — pjsip .
  • Новая внутренняя шина сообщений, которая передает данные о состоянии каналов, мостов, конечных устройств и других объектов по всему Asterisk.
  • Сильно обновленная версия AMI, c улучшенной семантикой канала и последовательности информации о событии.
  • Новый интерфейс ARI, позволяющий внешним приложениям управлять каналами, мостами и других объектами телефонии напрямую.

Ссылки
wiki.asterisk.org/wiki/display/AST/Asterisk+12+Documentation
wiki.asterisk.org/wiki/display/AST/New+in+12
blogs.digium.com/2013/06/28/asterisk_12_part_one/

Остановка и перезапуск Asterisk

  • Asterisk
Для остановки и перезагрузки Asterisk, есть несколько команд:
  • core stop now — Эта команда останавливает Asterisk немедленно, заканчивая все текущие вызовы.
  • core stop gracefully — Эта команда предотвращает новые вызовы, но позволяет закончить текущие звонки. Когда все звонки закончились, Asterisk останавливается.
  • core stop when convenient — Эта команда ждет, пока в Asterisk будет вызовов, а затем останавливает службу. Это не мешает новым вызовам.

Читать дальше →

Стеклянная память сможет хранить до 360 гигабайт на одном диске

Ученые английского университета в Саутгемптоне достигли успеха в создании накопителя чрезвычайной емкости с использованием технологии хранения данных в пяти измерениях (5D). Данный диск может хранить огромные объемы данных на стеклянной подложке, но в отличие от обычных DVD и Blu-ray дисков, может делать это на протяжении неограниченного срока времени без потери целостности данных. Ученые утверждают, что оптические 5D носители могут иметь плотность хранения данных до 360 гигабайт на диск и если их не уничтожать их сознательно, то хранимые на таких носителях данные могут пережить не одно поколение человека.

На первый взгляд, хранение данных в пяти измерениях звучит как некая фантастика. Но на самом деле в новой технологии предусмотрено хранение данных именно в пяти различных разрешениях – плоскостях или поверхностях, если хотите. В обычном кремниевом стекле существует два измерения – длина и ширина, а вот глубина записи данных происходит на трех различных уровнях стекла. Четвертый и пятый недостающие уровни обеспечиваются благодаря особой наноструктуре поверхности стекла, что приводит к рефракции и поляризации световых лучей по интересным законам.

Для записи данных, в специально отмеченных точках используется специальный высокочастотный лазер (работающий в фемтосекундном диапазоне частот). Фемтосекундный лазер в данном случае генерирует пучок, который светит всего 280 фемтосекунд (280 квадриллионов секунд). Это решение, благодаря поверхности накопителя с наноструктурой и некоторым возможностям голографического изображения поможет записать до трех бит данных в двух разрешениях.
Читать дальше →

Как заблокировать торренты на микротике

Довольно распространенная проблема в организациях — хотя бы один пользователь начинает качать торрент, забивая при этом весь канал и процессор роутера большим количеством запросов. Если у Вас установлен роутер от Mikrotik, можно заблокировать мусорный трафик. Для это запустим консоль и добавим следующие правила:

Читать дальше →

AsteriskNotifier – необходимый инструмент менеджера

AsteriskNotifier собственной разработки, предназначенной для управления списком контактов с возможностью набора номера и определения входящих телефонных вызовов.
AsteriskNotifier интегрируется с IP АТС Asterisk и в том числе Elastix, Trixbox, Freepbx и прочими пакетами основанными на Asterisk. Вы можете позвонить из программы абоненту просто нажав на номер телефона, при этом соединение произойдет через обычный настольный телефон или программный клиент используемый пользователем. При входящем звонке всплывает карточка абонента со всеми его данными.
Читать дальше →

Ошибка при обновлении NO_PUBKEY 07DC563D1F41B907

  • Linux
Для установки кодеков в Debian\Lenny добавил репозиторий www.debian-multimedia.org и при apt-get update получил ошибку GPG error:
W: GPG error: http://www.debian-multimedia.org squeeze Release:
The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 07DC563D1F41B907

Помогло следующее:
# apt-get install debian-keyring

И потом:
# gpg --keyring /usr/share/keyrings/debian-keyring.gpg -a --export 07DC563D1F41B907 |apt-key add -

После этого apt-get update отрабатывает без ошибок.

Не проходят вызовы или голос в asterisk?

  • Asterisk
Очень распространенная проблема с голосом по IP, когда нужно передать в другую сеть, то не слышно вас или собеседника. Сам бился много раз. Нашел в сети полезную схему как диагностировать проблему. Может кому пригодится в решении проблемы.



И еще одна схема дальше →

Как вывести конфигурацию микротика в текстовый файл или на консоль

  • Mikrotik
Вот так:
Показать конфиг в терминале
/export compact

Сохранить конфигурацию в файл
/export compact file=myconfig

При этом конфигурация микротика сохраняется в понятном текстовом виде, вроде
/interface bridge
add name=bridge1
/interface ethernet
set 0 comment=To-ADSL-Modem mtu=1480 name=WAN
set 1 comment=To-LAN-Switch name=LAN
set 2 master-port=LAN
set 3 master-port=LAN
set 4 master-port=LAN
и т.д.

Livestreet 1.0.2

Livestreet 1.0.2
Движок сайта обновлен с версии 0.5 на последнюю актуальную 1.0.2. Постепенно буду добавлять плагины и допиливать шаблон. Если найдете баги, прошу писать в комментах этой темы или в личку.

Правильный my.cnf для русской кодировки

  • Linux
Настройки MySQL для корректного отображения русских символов:

[client]
port = 3306
default-character-set=utf8

[mysqld]
port = 3306
init_connect='SET collation_connection = utf8_general_ci'
init_connect='SET NAMES utf8'
default-character-set=utf8
character-set-server = utf8
collation-server = utf8_general_ci

datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock

user=mysql
old_passwords=1

[mysql]
default-character-set=utf8

[mysqld_safe]
log-error=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid

36 ядерный маршрутизатор от Mikrotik и кое-что еще

Mikrotik представила свои, давно анонсированные, роутеры «облачной» серии. Первая новинка Cloud Core Router CCR1036-12G-4S
Cloud Core Router CCR1036-12G-4S Mikrotik
Самый мощный 36-ядерный роутер от Микротик. Каждое ядро 1,2ГГц, 12xГбит портов, 4Gb RAM, 4xSFP слота, RS232 и USB порт, корпус 1U, питание от POE. В CCR1036-12G-4S имеется два слота SODIMM (поддержка 16Gb RAM и более). Обещана скорость 8 mpps по стандарному роутингу и 15 при fastpath режиме роутинга. До 16 Gbit/s трафика. Цена для дилеров 790$, розница 995$.
Читать дальше →

Индикация состояния абонента в очереди на телефоне с BLF кнопками

imageСегодня задача немного посложнее.
Клиенту нужно, чтобы нажатием на кнопку быстрого набора можно было входить/выходить в очередь. При этом если абонент в очереди, то кнопка горит зеленым, если нет, то моргает красным. Сделать такое можно если IP само собой телефон поддерживает функцию BLF. Для работы функции на кнопке нужно будет прописать номер вида *12111*222, где 111 номер очереди, а 222 номер абонента. Тестировалось это на Grandstream GXP серии, самых разных. Сервером выступает Linux c Elastix, ну и можно просто Asterisk 1.6+.
Одним из условий является отсутствие привязки к номеру абонента. Номера очередей фиксированы, а абоненты могут быть любые. Для мониторинга состояния в Asterisk нужен HINT и если его нет, мы его будем создавать.
Читать дальше →

Индикация работы режима DnD на BLF клавише в Asterisk

  • Asterisk
DnD достаточно востребованная функция, но обычно режим включается на самом телефоне, не уведомляя об этом Asterisk, отчего тот будет обращаться к телефону пользователя, думая, что тот на месте и готов ответить на звонок. Как нам включить режим DnD на самом Asterisk и чтобы кнопка включения при активированном DnD моргала красным цветом?
Для этого нам потребуется телефон с BLF кнопками и пара макросов.
Читать дальше →