Настройка EIGRP на Cisco часть 4 [подготовка к CCNP]

Cisco

4. Настройка среды Frame Relay и маршрутизации в зоне 200


Это четвертая часть моей статьи по настройке EIGRP в рамках экзамена CCNP Route.

Перейти к первой части
Перейти ко второй части
Перейти к третьей части

]Первым делом настроим маршрутизаторы для работы с frame relay, в соответствии с рисунком сети.
В данном случае будем использовать неполносвязную сеть (прямой связи R5-R6 не будет). Благодаря этому можно будет посмотреть несколько интересных особенностей при конфигурировании Eigrp.
Важно на интерфейсах в frame relay установить параметр bandwidth равный CIF. Так как маршрутизаторы передают eigrp сообщения со скоростью равной половине bandwidth (50%).
Этот процент можно изменить командой (interface)#ip bandwich-percent eigrp [ANS][процент]

R4(config)#int s0/0
R4(config-if)#no sh
R4(config-if)#encapsulation frame-relay
R4(config-if)#clock rate 64000
R4(config-if)#exit
R4(config)#int s0/0.1 multipoint — создаем мультипоит интрефейс
R4(config-subif)#ip address 8.8.8.4 255.255.255.0
R4(config-subif)#frame-relay map ip 8.8.8.6 106 – статически связываем ip адреса и DLCI
R4(config-subif)#frame-relay map ip 8.8.8.5 105
R4(config-subif)#bandwidth 128 – устанавливаем в значение 2хCIF. Так как на мультипоинт интерфейсах это значение делится на все PVC (у нас два PVC c CIF 64 Кбит/с).


Настраиваем R5:
R5(config)#int s1/0
R5(config-if)#encapsulation frame-relay
R5(config-if)#int s1/0.1 point-to-point – здесь используем точка-точка интерфейс
R5(config-subif)#ip address 8.8.8.5 255.255.255.0
R5(config-subif)#frame-relay interface-dlci 104 – связываем с интерфейсом DLCI
R5(config-subif)#bandwidth 64
R5(config-fr-dlci)#exit
R5(config-subif)#end
R5(config)#int lo1
R5(config-if)#ip address 172.16.0.1 255.255.0.0
R5(config-if)#no sh
R5(config-if)#int lo2
R5(config-if)#ip address 172.17.0.1 255.255.0.0
R5(config-if)#no sh


Аналогично R5 настраивается и R6.

FR1 который является Frame Relay коммутатором настраиваем следующим образом:

Это делается из контекстного меню коммутатора на вкладке Configure. Логика работы проста, на примере верхней строки: если на первый порт пришел кадр с DLCI 105 то поменять DLCI на 104 и отправить с порта 3.
Убедимся в работоспособности среды Frame relay, проведя пинги между R5-R4 и R5-R6.

Пинги доходят до обоих маршрутизаторов, хотя и сеть не полносвязная, но R4 перенаправляет запросы на нужный маршрутизатор. Однако, стать соседями в eigrp R5 и R6 не смогут, так как нет прямого канала связи между ними.

Теперь можно переходить к настройке EIGRP в автономной системе 200.

Здесь я не буду использовать динамическое обнаружение соседей. В среде frame-relay удобнее использовать статическую привязку соседей, чтобы не пересылать копии сообщений на все PVC (таких PVC в реальной сети может быть очень большое количество).

R4(config)#router eigrp 200
R4(config-router)#neighbor 8.8.8.5 serial 0/0.1 – этой командой задается статический сосед и доступен он с интерфейса s0/0.1
R4(config-router)#neighbor 8.8.8.6 serial 0/0.1
R4(config-router)#network 8.8.8.0 0.0.0.255
R4(config-router)#passive-interface default
R4(config-router)#no passive-interface s0/0.1
R4(config-router)#end
R4#wr


При этом, как заверяют книги Cisco Press, больше не нужно вводить команды network чтобы включить интерфейс в eigrp. Однако, network вводить все же пришлось.
После ввода команды neighbor интерфейс перестанет принимать мультиадресные сообщения, поэтому нужно настраивать данную команду с двух сторон.
Убедимся, что мы настроили именно статических соседей.

Это видно по строке Static neighbor в eigrp neighbors for process 200
Посмотрим соседей на R5.

Здесь указан только один сосед R4, так как нет прямого канала связи между R5 и R6.
В выводе команды не указано, что это статический сосед. Данная информация выводится только по дополнительной команде detail.
Если мы посмотрим таблицу маршрутизации R5, мы не увидим там маршрутов для каких либо других сетей, кроме непосредственно подключенных к нему.

Хотя на R4 таблица маршрутизации для зоны 200 содержит все маршруты.

Это связано с двумя причинами. Во-первых, для передачи маршрутов из автономной системы 100 в 200 необходимо настроить дополнительно перераспределение маршрутов, чем мы скоро займемся. А во-вторых, причина по которой R5 не имеет маршрутов в R6 (хотя они в одной автономной системе) связана с тем, что на интерфейсе s0/0.1 R4 действует правило расщепления горизонта. Это правило запрещает отправлять обновления о сетях с интерфейса на который они же были получены.
Отключим это правило.

R4(config-subif)#no ip split-horizon eigrp 200
R4(config-subif)#
*Mar 1 01:20:59.095: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 200: Neighbor 8.8.8.6 (Serial1/0.1) is resync: split horizon changed
*Mar 1 01:20:59.095: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 200: Neighbor 8.8.8.5 (Serial1/0.1) is resync: split horizon changed


И посмотрим, что стало с таблицей маршрутизации R5.

Видно, что сети из R6 стали доступны на R5.

Теперь я покажу как настроить доступность сетей из одной автономной системы в другой.

Перейти к пятой части
Перейти к шестой части
Перейти к седьмой части
Перейти к восьмой части">

3 комментария

Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.