Настройка EIGRP на Cisco часть 2 [подготовка к CCNP]

Cisco

2. Базовые настройки EIGRP в зоне 100

Это вторая часть моей статьи по настройке EIGRP в рамках экзамена CCNP Route.
Перейти к первой части

]Я предполагаю, что базовая настройка маршрутизаторов у Вас уже произведена.

R1(config)#router eigrp 100 – включаем eigrp с номером процесса 100
R1(config-router)#network 1.1.1.0 0.0.0.255 – добавляем анонсируемые сети и соответствующие интрерфейсы
R1(config-router)#network 1.1.2.0 0.0.0.255
R1(config-router)#network 1.1.3.0 0.0.0.255
R1(config-router)#network 10.10.10.0 0.0.0.255
R1(config-router)#network 11.11.11.12 0.0.0.3
R1(config-router)#passive-interface default – переключаем все интерфейсы в пассивный режим (не будут анонсировать маршруты).
R1(config-router)#no passive-interface fa0/0 – исключаем из пассивного режима интрефейсы по которым необходимо устанавливаеть соседство
R1(config-router)#no passive-interface fa0/1
R1(config-router)#no auto-summary – отключим автоматическое суммирование, иначе все сети с loopback интерфейсов будут анонсироваться суммарным маршрутом с маской /8.
R1(config-router)#exit


После настройки соседних маршрутизаторов видим, что они стали соседями, значит все параметры соседства совпадают:

R2(config)#router eigrp 100
R2(config-router)#network 10.10.10.0 0.0.0.255
R2(config-router)#
*Mar 1 00:14:38.335: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 10.10.10.1 (FastEthernet0/0) is up: new adjacency


Смотрим таблицу маршрутизации R1:

Видно, что все сети доступны. Аналогичную таблицу можно посмотреть и на других маршрутизаторах.
На этом можно считать, что базовая настройка в зоне 100 сделана.
Для надежности проверим расширенным pingом доступность из интерфейса Lo1 R1 интерфейс Lo1 R4 и посмотрим какой путь проходят пакеты

Параметр Record позволит показать не только путь, который проходит пакет, но и обратный маршрут.
Данный пример удобен еще и тем, что в нем видно как срабатывает балансировка на маршрутизаторах. Согласно таблице маршрутизации сеть 4.4.4.0 достижима из R1 по двум путям: через 10.10.10.8 (R8) и 10.10.10.2 (R2). Благодаря этому первый ICMP был направлен через R8 (выходной интерфейс 11.11.11.5), а второй – через R2 (выходной интерфейс 11.11.11.1).
Конечно, судя по топологии сеть 4.4.4.0 может быть достижима и через R7, но этого маршрута нет в таблице маршрутизации, потому что его метрика получилась больше (из-за меньшего параметра bandwidth и большего delay на соответствующих интерфейсах). Позже я буду настраивать резервные маршруты в сети, где подробнее расскажу о маршрутах, которые добавляются в таблицу маршрутизации.

Перейти к первой части

Перейти к третьей части
Перейти к четвертой части
Перейти к пятой части
Перейти к шестой части
Перейти к седьмой части
Перейти к восьмой части">

6 комментариев

Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.