Полезные команды в Cisco IOS [5]

Cisco
Горячие клавиши

Полезные сочетания клавиш, чтобы лишний раз не пользоваться мышкой.

Ctrl+A — Передвинуть курсор на начало строки
Ctrl+E — Передвинуть курсор на конец строки
Up — Последняя команда из истории
Down — Следующая команда из истории
Ctrl+W — Стереть предыдущее слово
Ctrl+U — Стереть всю линию
Ctrl+C — Выход из режима конфигурирования
Ctrl+Z — Применить текущую команду и выйти из режима конфигурирования
Ctrl+Shift+6 — Остановка длительных процессов — тот самый «Type escape sequence to abort»

Параметры вывода

После основного текста команды через символ | можно указать модификаторы вывода, которые очень полезны. Ими можно фильтровать строки, секции, позицию вывода. Вот основные:
1. Begin
Выведет все начиная со строки в которой будет вхождение параметра, например «sh run | begin int» выведет все начиная со строки в которой встретится «int»
router#sh run | begin int
parser config cache interface
service tcp-keepalives-in
service tcp-keepalives-out

2. Section
Выведет указанные секции, например «sh run | section int» выведет все секции в названиях которых есть «int»
router#sh run | section int
parser config cache interface
interface Loopback0
 ip address 192.168.1.21 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 shutdown
interface Null0
 no ip unreachables

3. Exclude
Выведет строки в которых нет вхождения параметра, например «sh run | exclude int» выведет строки в которых нет «int»

4. Include
Выведет строки в которых есть вхождения параметра, например «sh run | include int» выведет строки в которых есть «int»

В параметре можно использовать регулярные выражения, например:
router#show run | inc ^interface|ip address
interface Loopback0
 ip address 192.168.1.1 255.255.255.0
interface Null0
interface GigabitEthernet0/0
 ip address 11.11.12.10 255.255.255.240
interface Serial0/2/0
 no ip address
interface Vlan1
 no ip address

и
router#sh ip int | inc line protocol|access list is [^ ]+$
GigabitEthernet0/0 is up, line protocol is up
  Outgoing access list is 100
  Inbound  access list is 200
GigabitEthernet0/1 is up, line protocol is up
  Outgoing access list is 101


Похожие статьи:
Полезные команды в Cisco IOS [1]
Полезные команды в Cisco IOS [2]
Полезные команды в Cisco IOS [3]
Полезные команды в Cisco IOS [4]
Полезные команды в Cisco IOS [6]

1 комментарий

Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.