Настройка маршрутизаторов Cisco

Cisco
Я уже выкладывал в этом блоге несколько постов про команды cisco ios, но они служат в том числе и справочником мне, потому что я иногда возвращаюсь к ним, чтобы вспомнить команды. Теперь я решил написать статьи про начальную настройку маршрутизаторов cisco, потому что вопросы по ним возникают часто, а ссылку дать и некуда :)

Итак подключаемся к роутеру с помощью hyperterminal по шнурку, который должен быть в комплекте с cisco`й. Для подключения через usb я использую конвертер usb-com от STLab.

— Удаляем заводские настройки
erase startup-config

— Включаем шифрование паролей и еще пару необходимых настроек базы пользователей
service password-encryption
aaa new-model
aaa authentication login default local
security passwords min-length 6

— Заводим админский логин
username admin privilege 15 password 0 PASSWORD

— Настраиваем имя маршрутизатора
hostname cisco_gw
ip domain-name cisco_gw.local

— Включаем и настраиваем удаленный доступ по SSH
ip ssh time-out 60
ip ssh authentication-retries 2
ip ssh version 2
line vty 0 4
 transport input telnet ssh
 privilege level 15

— Включаем Cisco's Express Forwarding (CEF) — ускоренную коммутацию пакетов
ip cef

— Настроим сервис времени
ntp server 194.149.67.130
ntp server 62.117.76.139
ntp server 130.159.196.118

— Можно включить сервер времени на самом маршрутизаторе, чтобы локальные устройства брали время с него
ntp master 10

— Включаем архивирование всех изменений конфига, скрывая пароли в логах
archive
 log config
  logging enable
  hidekeys
(историю изменения конфига можно посмотреть командой show archive log config all)

— Настроим DNS
ip domain-lookup
ip dns server
ip name-server XXX.XXX.XXX.XXX
ip name-server 8.8.8.8

— Настроим интерфейс локальной сети и «смотрящий» в интернет
interface GigabitEthernet0/1
 description LAN
 ip address 192.168.0.1 255.255.255.0
 ip nat inside
 duplex full
 speed auto

interface GigabitEthernet0/0
 description LAN
 ip address 11.22.33.44 255.255.255.252
 ip nat outside
 duplex full
 speed auto

— Делаем пару необходимых настроек о которых я уже писал
Настройка DHCP сервера
Настройка безопасного интернет соединения

-Включаем роутинг в интернет
ip route 0.0.0.0 0.0.0.0 11.22.33.44

— Включаем NAT
ip access-list extended NAT
 permit ip 192.168.0.0 255.255.255. any
ip nat inside source list NAT interface GigabitEthernet0/0 overload

0 комментариев

Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.