Cisco маршрутизатор и 2 провайдера

Cisco
Нашей задачей будет заставить работать 2 внешних интерфейса одновременно с автоматическим переключением на рабочий. Плюс немного усложним задачу, часть трафика нужно будет принудительно направить в резервный канал независимо от работоспособности.

Схема подключения


Настройки

Настройки интерфейсов стандартные: FastEthernet0/0 смотрит в провайдера номер раз, FastEthernet0/1 в локалку, FastEthernet0/2 в провайдера номер два.

interface FastEthernet0/0
 description $ISP1$
 ip address 11.11.11.2 255.255.255.252
 ip nat outside
 
interface FastEthernet0/1
 description LAN
 ip address 10.0.0.1 255.255.255.0
 ip nat inside
!
interface FastEthernet0/2
 description $ISP2$
 ip address 22.22.22.2 255.255.255.252
 ip nat outside
! 

Настроим NAT
ip nat inside source route-map 111 interface FastEthernet0/0 overload
ip nat inside source route-map 112 interface FastEthernet0/2 overload

Настроим слежение за состоянием каналов
track 123 ip sla 1 reachability
track 124 ip sla 2 reachability

ip sla 1
 icmp-echo 11.11.11.1 source-interface FastEthernet0/0
 request-data-size 32
 timeout 500
 frequency 5
 history hours-of-statistics-kept 24
ip sla schedule 1 life forever start-time now
ip sla 2
 icmp-echo 22.22.22.1 source-interface FastEthernet0/2
 request-data-size 32
 timeout 500
 frequency 5
 history hours-of-statistics-kept 24
ip sla schedule 2 life forever start-time now

route-map tracking permit 10
 set ip next-hop verify-availability 11.11.11.1 10 track 123
 set ip next-hop 11.11.11.1
!
route-map tracking permit 20
 set ip next-hop verify-availability 22.22.22.1 20 track 124
 set ip next-hop 22.22.22.1

Ну и добавляем маршрутизацию, причем будет дополнительный маршрут в локалку 2ого провайдера и в route-map будет отрабатываться исключение этого направления из первого nat первого провайдера.
ip route 0.0.0.0 0.0.0.0 11.11.11.1 10 track 123
ip route 0.0.0.0 0.0.0.0 22.22.22.1 20 track 124
ip route 172.18.48.0 255.255.255.0 22.22.22.1

route-map 111 deny 5
 match ip address 117
!
route-map 111 permit 10
 match ip address 115
 match interface FastEthernet0/0
 set ip next-hop 11.11.11.1
!
route-map 112 permit 10
 match ip address 116
 match interface FastEthernet0/2
 set ip next-hop 22.22.22.1
!

Проверка работы
Состояние работы проверки каналов можно смотреть командой sh ip sla statistics details
Проверка работы NAT`а команда show ip nat translations
Если будут вопросы по настройке, задавайте, с удовольствием постараюсь помочь.

21 комментарий

avatar
Хм, а зачем 3 маршрутизатора? и судя по настройкам на второго провайдера трафик не балансируется, т.е. канал просто простаивает :)
avatar
в этом случае да :) ну вариантов много. это один из :)
avatar
Вот я ступил сразу :))))))) Какие 3 провайдера??? Это шлюзы у провайдеров имелись ввиду. Их состояние я и проверяю :)
avatar
В данной схеме — будет проверяться возможность пропинговать адрес провайдера :)
схема [myRouter] — [provider] x (inet).
У провайдера упал апстрим, пинг провайдера есть, а интернет не работает. Что делать?
avatar
Представь себе версия прошивки на которой эта схема и работает может пинговать интерфейсы только directly connected. Пробовал на новой версии разводить по ya.ru rambler.ru и прочим гуглам, но чем-то не устроило, вернулся к первому варианту. Если память не изменяет, то они периодически пропадали, хоть 80 порт отвечал :) по разным интерфейсам сайты разводил статическими маршрутами